## main_index  <<MYMFC21D>> Help Index

How To ...
	<<add your application-specific "how to" topics here>>

Commands
	File menumenu_file
	Edit menumenu_edit
	Record menumenu_record
	View menumenu_view
	Window menumenu_window
	Help menumenu_help

## menu_fileKK files: managing $$ File menu commands File menu commands

The File menu offers the following commands:

NewHID_FILE_NEW
Creates a new document.
OpenHID_FILE_OPEN
Opens an existing document.
CloseHID_FILE_CLOSE
Closes an opened document.
SaveHID_FILE_SAVE
Saves an opened document using the same file name.
Save AsHID_FILE_SAVE_AS
Saves an opened document to a specified file name.
PrintHID_FILE_PRINT
Prints a document.
Print PreviewHID_FILE_PRINT_PREVIEW
Displays the document on the screen as it would appear printed.
Print SetupHID_FILE_PRINT_SETUP
Selects a printer and printer connection.
Send...HID_FILE_SEND_MAIL
Sends the active document through electronic mail.
ExitHID_APP_EXIT	

Exits <<MYMFC21D>>.


## menu_editEdit menu commands

The Edit menu offers the following commands:

UndoHID_EDIT_UNDO
Reverse previous editing operation.
CutHID_EDIT_CUT
Deletes data from the document and moves it to the clipboard.
CopyHID_EDIT_COPY
Copies data from the document to the clipboard.
PasteHID_EDIT_PASTE
Pastes data from the clipboard into the document.
Paste LinkHID_EDIT_PASTE_LINK
Pastes from the clipboard a link to data in another application.
Insert New ObjectHID_OLE_INSERT_NEW
Inserts and embeds an object, such as a chart or an equation in a document.
LinksHID_OLE_EDIT_LINKS
List and edit links to embedded documents.

	
## menu_viewView menu commands

The View menu offers the following commands:

ToolbarHID_VIEW_TOOLBAR
Shows or hides the toolbar.
Status BarHID_VIEW_STATUS_BAR
Shows or hides the status bar.


## menu_windowWindow menu commands

The Window menu offers the following commands, which enable you to arrange multiple views of multiple documents in the application window:

New WindowHID_WINDOW_NEW
Creates a new window that views the same document.
CascadeHID_WINDOW_CASCADE
Arranges windows in an overlapped fashion.
TileHID_WINDOW_TILE
Arranges windows in non-overlapped tiles.
Arrange IconsHID_WINDOW_ARRANGE
Arranges icons of closed windows.
SplitHID_WINDOW_SPLIT
Split the active window into panes.
Window 1, 2, ...HID_WINDOW_ALL
Goes to specified window.



## menu_helpHelp menu commands

The Help menu offers the following commands, which provide you assistance with this application: 

Help TopicsHID_HELP_INDEX
Offers you an index to topics on which you can get help.
AboutHID_APP_ABOUT
Displays the version number of this application.



## HID_FILE_NEWKK files: managing $$ File New command New command (File menu)

Use this command to create a new document in <<MYMFC21D>>.  Select the type of new file you want to create in the File New dialog boxAFX_HIDD_NEWTYPEDLG.  << Remove previous sentence if your application supports only one document type. >>

You can open an existing document with the Open commandHID_FILE_OPEN.

Shortcuts
Toolbar:	{bmc filenew.bmp}
Keys:	CTRL+N


## AFX_HIDD_NEWTYPEDLGFile New dialog box

<< Delete this help topic if your application supports only one document type. >>

Specify the type of document you wish to create:
<< List your application's document types here >>
## HID_FILE_OPENKK files: managing $$ File Open command Open command (File menu)

Use this command to open an existing document in a new window.  You can open multiple documents at once.  Use the Window menu to switch among the multiple open documents.  See Window 1, 2, ... commandHID_WINDOW_ALL.

You can create new documents with the New commandHID_FILE_NEW.

Shortcuts
Toolbar:	{bmc fileopen.bmp}
Keys:	CTRL+O


## AFX_HIDD_FILEOPENFile Open dialog box

The following options allow you to specify which file to open:
File Name
Type or select the filename you want to open.  This box lists files with the extension you select in the List Files of Type box. 
List Files of Type
Select the type of file you want to open:
<< List your application's file types here. >>
Drives
Select the drive in which <<MYMFC21D>> stores the file that you want to open. 
Directories
Select the directory in which <<MYMFC21D>> stores the file that you want to open.
Network...
Choose this button to connect to a network location, assigning it a new drive letter. 


## HID_FILE_CLOSEKK files: managing $$ File Close command Close command (File menu)

Use this command to close all windows containing the active document.  <<MYMFC21D>> suggests that you save changes to your document before you close it.  If you close a document without saving, you lose all changes made since the last time you saved it.  Before closing an untitled document, <<MYMFC21D>> displays the Save As dialog boxAFX_HIDD_FILESAVE and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown below:
{bml scmenu.bmp}

## HID_FILE_SAVEKK files: managing $$ File Save command Save command (File menu)

Use this command to save the active document to its current name and directory.  When you save a document for the first time, <<MYMFC21D>> displays the Save As dialog boxAFX_HIDD_FILESAVE so you can name your document.  If you want to change the name and directory of an existing document before you save it, choose the Save As commandHID_FILE_SAVE_AS.

Shortcuts
Toolbar:	{bmc filesave.bmp}
Keys:	CTRL+S



## HID_FILE_SAVE_ASKK files: managing $$ File Save As command Save As command (File menu)

Use this command to save and name the active document.  <<MYMFC21D>> displays the Save As dialog boxAFX_HIDD_FILESAVE so you can name your document.  

To save a document with its existing name and directory, use the Save commandHID_FILE_SAVE.


## HID_FILE_SEND_MAILSend command (File menu)

Use this command to send the active document through electronic mail.  This command presents a mail window with the active document attached to it.  You may then fill out the To: field, Subject: field, etc., and add text to the body of the message if you wish.  When you are finished you may click the "Send" button to send the message.

## AFX_HIDD_FILESAVEFile Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name
Type a new filename to save a document with a different name.  <<MYMFC21D>> adds the extension you specify in the Save File As Type box.
Drives
Select the drive in which you want to store the document.
Directories
Select the directory in which you want to store the document.
Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

<< Add other File Save As dialog box options depending on which ones your application chooses via the OFN_ flags of the OPENFILENAME structure used by the CFileDialog. >>

## HID_FILE_MRU_FILE1 KK files: managing $$ File 1, 2, 3, 4 command 1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four documents you closed.  Choose the number that corresponds with the document you want to open.

## HID_APP_EXITKK exit $$ File Exit command Exit command (File menu)

Use this command to end your <<MYMFC21D>> session.  You can also use the Close command on the application Control menu.  <<MYMFC21D>> prompts you to save documents with unsaved changes.

Shortcuts
Mouse:	Double-click the application's Control menu button.
	{bmc appexit.bmp}
Keys:	ALT+F4

## HID_EDIT_UNDOUndo/Can't Undo command (Edit menu)

<< Your application's user interface for Undo may differ from the one described below.  Modify this help text accordingly. >>

Use this command to reverse the last editing action, if possible.   The name of the command changes, depending on what the last action was.  The Undo command changes to Can't Undo on the menu if you cannot reverse your last action.

Shortcuts
Toolbar:	{bmc editundo.bmp}
Keys:	CTRL+Z or
	ALT-BACKSPACE	


## HID_EDIT_REDORedo command (Edit menu)

<< Write application-specific help here. >>

## HID_EDIT_CUTCut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on the clipboard.  This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar:	{bmc editcut.bmp}
Keys:	CTRL+X


## HID_EDIT_COPYCopy command (Edit menu)

Use this command to copy selected data onto the clipboard.  This command is unavailable if there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar:	{bmc editcopy.bmp}
Keys:	CTRL+C


## HID_EDIT_PASTEPaste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.  This command is unavailable if the clipboard is empty.

Shortcuts
Toolbar:	{bmc editpast.bmp}
Keys:	CTRL+V


## HID_VIEW_TOOLBARKK toolbar $$ View Toolbar command Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the most common commands in <<MYMFC21D>>, such as File Open.  A check mark appears next to the menu item when the Toolbar is displayed.

See ToolbarAFX_HIDW_TOOLBAR for help on using the toolbar.

## AFX_HIDW_TOOLBARKK toolbar $$ toolbar Toolbar
{bml hlptbar.bmp}

The toolbar is displayed across the top of the application window, below the menu bar.  The toolbar provides quick mouse access to many tools used in <<MYMFC21D>>,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

<< Add or remove toolbar buttons from the list below according to which ones your application offers. >>

Click	To
{bmc filenew.bmp}	Open a new document.

{bmc fileopen.bmp}	Open an existing document.  <<MYMFC21D>> displays the Open dialog box, in which you can locate and open the desired file.

{bmc filesave.bmp}	Save the active document or template with its current name.  If you have not named the document, <<MYMFC21D>> displays the Save As dialog box.

{bmc fileprnt.bmp}	Print the active document.

{bmc editcut.bmp}	Remove selected data from the document and stores it on the clipboard.

{bmc editcopy.bmp}	Copy the selection to the clipboard.

{bmc editpast.bmp}	Insert the contents of the clipboard at the insertion point.

{bmc editundo.bmp}	Reverse the last editing.  Note:  You cannot undo some actions.

{bmc recfirst.bmp}	Go to the first record in the current selection.

{bmc recprev.bmp}	Go to the previous record in the current selection.

{bmc recnext.bmp}	Go to the next record in the current selection.

{bmc reclast.bmp}	Go to the last record in the current selection.


## HID_VIEW_STATUS_BARKK status bar $$ View Status Bar CommandStatus Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be executed by the selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears next to the menu item when the Status Bar is displayed.

See Status BarAFX_HIDW_STATUS_BAR for help on using the status bar.

## AFX_HIDW_STATUS_BARKK status bar $$ status barStatus Bar
{bml hlpsbar.bmp}

The status bar is displayed at the bottom of the <<MYMFC21D>> window.  To display or hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to navigate through menus.  This area similarly shows messages that describe the actions of toolbar buttons as you depress them, before releasing them.  If after viewing the description of the toolbar button command you wish not to execute the command, then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator	Description
CAP	The Caps Lock key is latched down.
NUM	The Num Lock key is latched down.
SCRL	The Scroll Lock key is latched down.

## HID_WINDOW_NEWNew command (Window menu)

Use this command to open a new window with the same contents as the active window.  You can open multiple document windows to display different parts or views of a document at the same time.  If you change the contents in one window, all other windows containing the same document reflect those changes.  When you open a new window, it becomes the active window and is displayed on top of all other open windows.


## HID_WINDOW_CASCADECascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 


## HID_WINDOW_TILETile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



## HID_WINDOW_TILE_HORZTile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped fashion.

## HID_WINDOW_TILE_VERTTile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.

## HID_WINDOW_ARRANGEWindow Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main window.  If there is an open document window at the bottom of the main window, then some or all of the icons may not be visible because they will be underneath this document window.
## HID_WINDOW_SPLITSplit Command (Window menu)

Use this command to split the active window into panes.  You may then use the mouse or the keyboard arrows to move the splitter bars.  When you are finished, press the mouse button or enter to leave the splitter bars in their new location.  Pressing escape keeps the splitter bars in their original location.  << In a single document interface application, this command will appear on the View menu. >>
## HID_WINDOW_ALL1, 2, ... command (Window menu)

<<MYMFC21D>> displays a list of currently open document windows at the bottom of the Window menu.  A check mark appears in front of the document name of the active window.  Choose a document from this list to make its window active.  

## HID_HELP_INDEXIndex command (Help menu)

Use this command to display the opening screen of Help.  From the opening screen, you can jump to step-by-step instructions for using <<MYMFC21D>> and various types of reference information.  

Once you open Help, you can click the Contents button whenever you want to return to the opening screen.


## HID_HELP_USINGUsing Help command (Help menu)

Use this command for instructions about using Help.

## HID_APP_ABOUTAbout command (Help menu)

Use this command to display the copyright notice and version number of your copy of <<MYMFC21D>>.

## HID_CONTEXT_HELP$$ Help Using Help CommandContext Help command 
{bml curhelp.bmp}

Use the Context Help command to obtain help on some portion of <<MYMFC21D>>.  When you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.  Then click somewhere in the <<MYMFC21D>> window, such as another Toolbar button.  The Help topic will be shown for the item you clicked.

Shortcut
Keys:	SHIFT+F1

## HID_HT_CAPTIONTitle Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.  It contains the name of the application and document.

To move the window, drag the title bar.  Note: You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:
{bmc bullet.bmp}	Application Control-menu button
{bmc bullet.bmp}	Document Control-menu button
{bmc bullet.bmp}	Maximize button
{bmc bullet.bmp}	Minimize button
{bmc bullet.bmp}	Name of the application
{bmc bullet.bmp}	Name of the document
{bmc bullet.bmp}	Restore button

## scrollbars Scroll bars

Displayed at the right and bottom edges of the document window.  The scroll boxes inside the scroll bars indicate your vertical and horizontal location in the document.  You can use the mouse to scroll to other parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave in your application. >>

## HID_SC_SIZESize command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow keys.
{bml curarw4.bmp}

After the pointer changes to the four-headed arrow:
1.	Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the border you want to move.  
2.	Press a DIRECTION key to move the border.
3.	Press ENTER when the window is the size you want.

Note:  This command is unavailable if you maximize the window.

Shortcut
Mouse:	Drag the size bars at the corners or edges of the window.


## HID_SC_MOVEMove command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with the arrow keys.
{bmc curarw4.bmp}

Note:  This command is unavailable if you maximize the window.

Shortcut
Keys:	CTRL+F7


## HID_SC_MINIMIZE$$ System Minimize CommandMinimize command (application Control menu)

Use this command to reduce the <<MYMFC21D>> window to an icon.

Shortcut
Mouse:	Click the minimize icon {bmc scmin.bmp} on the title bar.
Keys:	ALT+F9


## HID_SC_MAXIMIZEMaximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse:	Click the maximize icon {bmc scmax.bmp} on the title bar; or double-click the title bar.
Keys:	CTRL+F10 enlarges a document window.


## HID_SC_NEXTWINDOWNext Window command (document Control menu)

Use this command to switch to the next open document window.  <<MYMFC21D>> determines which window is next according to the order in which you opened the windows.

Shortcut
Keys:	CTRL+F6


## HID_SC_PREVWINDOWPrevious Window command (document Control menu)

Use this command to switch to the previous open document window.  <<MYMFC21D>> determines which window is previous according to the order in which you opened the windows.

Shortcut
Keys:	SHIFT+CTRL+F6


## HID_SC_CLOSEClose command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.
{bml appexit.bmp}

Note:  If you have multiple windows open for a single document, the Close command on the document Control menu closes only one window at a time.  You can close all windows at once with the Close command on the File menu.

Shortcuts
Keys: 	CTRL+F4 closes a document window
	ALT+F4 closes the <<YourType>> window or dialog box
			
## HID_SC_RESTORERestore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or Minimize command.

## HID_SC_TASKLISTSwitch to command (application Control menu)

Use this command to display a list of all open applications.  Use this "Task List" to switch to or close an application on the list.

Shortcut
Keys:	CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following options:
Task List
Select the application you want to switch to or close.
Switch To
Makes the selected application active.
End Task
Closes the selected application.
Cancel
Closes the Task List box.
Cascade
Arranges open applications so they overlap and you can see each title bar.  This option does not affect applications reduced to icons.
Tile
Arranges open applications into windows that do not overlap.  This option does not affect applications reduced to icons.
Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.

## HID_VIEW_RULER$$ View Ruler CommandRuler command (View menu)

<< Write application-specific help here. >>

## AFX_HIDD_FONT$$ Choose Font DialogChoose Font dialog box

<< Write application-specific help here. >>

## AFX_HIDD_COLOR$$ Choose Color DialogChoose Color dialog box

<< Write application-specific help here. >>

## HID_EDIT_FIND$$ Edit Find CommandFind command (Edit menu)

<< Write application-specific help here. >>

## AFX_HIDD_FIND$$ Find DialogFind dialog box

<< Write application-specific help here. >>

## HID_EDIT_REPLACE$$ Edit Replace CommandReplace command (Edit menu)

<< Write application-specific help here. >>

## AFX_HIDD_REPLACE$$ Replace DialogReplace dialog box

<< Write application-specific help here. >>

## HID_EDIT_REPEAT$$ Edit Repeat CommandRepeat command (Edit menu)

Use this command to repeat the last editing command carried out.  The Repeat menu item changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key:	F4


## HID_EDIT_CLEAR$$ Edit Clear CommandClear command (Edit menu)

<< Write application-specific help here. >>

## HID_EDIT_CLEAR_ALL$$ Edit Clear AllClear All command (Edit menu)

<< Write application-specific help here. >>

## HID_NEXT_PANE$$ Next Pane CommandNext Pane

<< Write application-specific help here. >>

## HID_PREV_PANE$$ Prev Pane CommandPrev Pane

<< Write application-specific help here. >>

## HIDR_DOC1TYPEModifying the Document

<< Write application-specific help here that provides an overview of how the user should modify a document using your application.>>




## HID_HT_NOWHERENo Help Available

No help is available for this area of the window.

## AFX_HIDP_default
 No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each AFX_HIDP_xxx value.  For example, AFX_HIDP_INVALID_FILENAME is the help topic for the Invalid Filename message box. >>


## HID_WINDOW_NEW_STRINGNew String command (Window menu)

This is my customized menu to launch new window for string…

## HID_WINDOW_NEW_HEXNew Hex command (Window menu)

This is another customized window lol…



